Technology with attitude

Adobe Flash Player Latest Update – Upgrading Is a Must

0

It looks like Adobe has discharged a new patch as Flash Player was walking on thin ice and it was in need of this fix.

The team at Adobe has been working hard to release this new fix, this was a comeback to all those cyber attacks that were mostly targeting governmental institutes.

This new Flash Player fix came to see the light of day on Friday, the latter upgrade was meant to fix the CVE-2015-7645 vulnerability. It seems that Pawn Storms, a dangerous group from Russia is exploiting this one to the maximum along with two others, as noted by the analysts from Trend Micro.

This threat/vulnerability was later on corroborated by Adobe and they quickly decide to find a solution to this major problem, thus, the solution was quickly implemented, even quicker than Adobe anticipated.

Upgrade to the latest versions!

Those of you who are using Flash Player on Mac or Windows need to upgrade to the newest version, this being 19.0.0.226 and those who are on Linux must keep an eye out for 11.2.202.540 version. Also those who have Extended Support Release must make sure to upgrade to version 18.0.0.255.

Besides fixing the CVE-2015-7645 glitch, the updates that have been released are also aiming to solve the following glitches CVE-2015-7647 and CVE-2015-7648, as noted by Natalie Silvanovich( part of the Project Zero crew), if these are not fixed, the vulnerabilities are basically an open door for attackers to take full control of one’s PC.

Some users might have forgotten about Flash Player, but for those of you who cannot seem to let go of it, you could activate the click-to-play feature, which means that you can safely run Flash file, give it a try.